设为首页 收藏本站 切换到窄版
查看: 1232|回复: 0

【BPI-M2+】之OpenCV依赖包安装出错

[复制链接] qrcode

32

主题

33

帖子

101

积分

注册会员

Rank: 2

积分
101
发表于 2016-8-28 10:55 AM | 显示全部楼层 |阅读模式
参考网上安装OpenCV的方法,发现在安装必要的视频I/O包时出错
  1. sudo apt-get install libavcodec-dev libavformat-dev libswscale-dev libv4l-dev
复制代码

步骤1
安装所需的安装工具和包:
  1. sudo apt-get install build-essential cmake pkg-config
复制代码



步骤2
安装必要的图像I/O包,这样你才可以读入JPEG,PNG,TIFF等这些格式的图像。
  1. sudo apt-get install libjpeg8-dev libtiff4-dev libjasper-dev libpng12-dev
复制代码
没问题

步骤3
安装GTK开发库,这个库用来构建GUI。同时OpenCV中的highgui库也需要它来在屏幕上显示图像
  1. sudo apt-get install libgtk2.0-dev
复制代码
这一步也没问题

步骤4
安装必要的视频I/O包,OpenCV需要它们来读入视频文件。
  1. sudo apt-get install libavcodec-dev libavformat-dev libswscale-dev libv4l-dev
复制代码
这里最后一部分就出问题了,具体如下


提示缺少一些依赖,按照提示安装依然出现其他各种错误,不知道是不是前面安装方法错误

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表